using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bNon-GAAP\b.*?\b(\d+\.\d{2,})\b";
string input = @"Non-GAAP-2 net income of with EPS of 1.21, up 23% from the fourth quarter of 2020.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}