$re = '/(?i)^(?!.*?that).*$/m';
$str = 'I like this sentence
I like that sentence
I link THAT sentence';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);