$re = '/\|(.*)\|/';
$str = '"Here is some text that should not be replaced. | this is the string that needs to be replaced | this is some ending text that should not be replaced."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);