# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*(?<!\$)\b\d+/!/g;t' <<< "This is a number 100 but this isn't $100."