#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s*(?<!\$)\b\d+"
Local $sString = "This is a number 100 but this isn't $100."
Local $sSubst = "!"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)