use strict;
my $str = 'This is a number 100 but this isn\'t $100.';
my $regex = qr/\s*(?<!\$)\b\d+/p;
my $subst = '!';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";