import Foundation
let pattern = #"\s*(?<!\$)\b\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This is a number 100 but this isn't $100."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"!"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)