using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z_]*)_(UGEL[A-Z_0-9]*).pdf";
string input = @"LIMA_METROPOLITANA_UGEL_05_SAN_JUAN_DE_LURIGANCHO.pdf";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}