re = /([A-Z_]*)_(UGEL[A-Z_0-9]*).pdf/
str = 'LIMA_METROPOLITANA_UGEL_05_SAN_JUAN_DE_LURIGANCHO.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end