$re = '/^[a-zA-Z0-9]{32}_v2$/m';
$str = '_________________________________v2
1q2e5g6s4t5s2u1i5dy1s9u14i2s5u9o_v2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);