$re = '/((?:[^.]*?\.){2}[^.]*)\.(.*)/';
$str = 'My name is Resheil. I\'m developing in PHP. I have used mysql for my application. I want to replace the full stop on the nth position in php.';
$subst = "$1. Here I had a full stop.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;