using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[a-zA-Z])(\S+-\S+-\S+)";
string input = @"This 1-A16-19 person is BL-17-1111 and other
dont Z-1-12 do here but NOT 12-24-1981
numbers: 1A-256-29Q88 ok";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}