const regex = new RegExp('\\w*(?!\\B\\'\\B)\\'\\w*', 'gm')
const str = `I've never 'had somebody [redacted-number] [redacted-number] [redacted-number] not. not' you're 123'45 '`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}