$re = '/\w*(?!\B\'\B)\'\w*/m';
$str = 'I\'ve never \'had somebody [redacted-number] [redacted-number] [redacted-number] not. not\' you\'re 123\'45 \'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);