using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(build|ci|docs|feat|fix|perf|refactor|style|test|chore|revert)\([\w\-]+\):\s.*";
string input = @"Merge branch 'bla' of askfajl into aslfjkasld";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}