# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=")\p{Ll}/\U$0/gm;t' <<< "list: [\"required\",\"TBD at time of entry\", \"respirator, gloves, coveralls, etc.\"]"