using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\bfoo\b)(?=.*\bbar\b)(?=.*\bfoobar\b)(?=.*\bfootable\b)(?=.*\bsomebar\b)^(?:\w+\s+){4}\w+$";
string input = @"foo bar foobar footable somebar
foo bar footable somebar
foobar foo bar footable somebar
foo bar foobar footable somebar footable
foobar foo bar xyz somebar
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}