$re = '/(?=.*\bfoo\b)(?=.*\bbar\b)(?=.*\bfoobar\b)(?=.*\bfootable\b)(?=.*\bsomebar\b)^(?:\w+\s+){4}\w+$/m';
$str = 'foo bar foobar footable somebar
foo bar footable somebar
foobar foo bar footable somebar
foo bar foobar footable somebar footable
foobar foo bar xyz somebar
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);