$re = '/SUB([^,]*),-&succes/m';
$str = '-SUB12&100.000,-&failed&07/12/18SUB16&40.000,-&succes&09/12/18
SUB16&40.000,-&succes';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);