$re = '/<[^>]+>|[<>&]/m';
$str = '<p>text</p> <strong>bold</strong> and <em>italic</em> & <>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);