#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<iframe[^>]*?title=(\\\'|\\"|[\'"])([^>]*?)\1"
Local $sString = "<img src="..." title="title"/>" & @CRLF & _
"'<iframe src="..." title="title" width="324" height="auto"/>'" & @CRLF & _
""<iframe src='...' width='324' height='auto' title='title' ></iframe>"" & @CRLF & _
""<iframe src=\"...\" title=\"title\" width=\"324\" height=\"auto\"/>"" & @CRLF & _
"'<iframe src=\'...\' width=\'324\' height=\'auto\' title=\'title\' ></iframe>'" & @CRLF & _
""<iframe src=\"...\" title=\"title's with apostrophe\" width=\"324\" height=\"auto\"/>"" & @CRLF & _
""<iframe src='...' width='324' height='auto' title='title \"quoting\" something' ></iframe>"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")