import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<iframe[^>]*?title=(\\\\\\'|\\\\\"|[\\'\"])([^>]*?)\\1";
final String string = "<img src=\"...\" title=\"title\"/>\n"
+ "'<iframe src=\"...\" title=\"title\" width=\"324\" height=\"auto\"/>'\n"
+ "\"<iframe src='...' width='324' height='auto' title='title' ></iframe>\"\n"
+ "\"<iframe src=\\\"...\\\" title=\\\"title\\\" width=\\\"324\\\" height=\\\"auto\\\"/>\"\n"
+ "'<iframe src=\\'...\\' width=\\'324\\' height=\\'auto\\' title=\\'title\\' ></iframe>'\n"
+ "\"<iframe src=\\\"...\\\" title=\\\"title's with apostrophe\\\" width=\\\"324\\\" height=\\\"auto\\\"/>\"\n"
+ "\"<iframe src='...' width='324' height='auto' title='title \\\"quoting\\\" something' ></iframe>\"\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}