$re = '/<iframe[^>]*?title=(\\\\\'|\\\\"|[\'"])([^>]*?)\1/m';
$str = '<img src="..." title="title"/>
\'<iframe src="..." title="title" width="324" height="auto"/>\'
"<iframe src=\'...\' width=\'324\' height=\'auto\' title=\'title\' ></iframe>"
"<iframe src=\\"...\\" title=\\"title\\" width=\\"324\\" height=\\"auto\\"/>"
\'<iframe src=\\\'...\\\' width=\\\'324\\\' height=\\\'auto\\\' title=\\\'title\\\' ></iframe>\'
"<iframe src=\\"...\\" title=\\"title\'s with apostrophe\\" width=\\"324\\" height=\\"auto\\"/>"
"<iframe src=\'...\' width=\'324\' height=\'auto\' title=\'title \\"quoting\\" something\' ></iframe>"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);