use strict;
my $str = 'ИС-5 B/1 D.06\' (Объект 730)
ИС-5 B/1 Dd06\' (Объект 730)
ИС-5 B/1 D!06\' (Объект 730)
ИС-5 B/1 D_06\' (Объект 730)
#ИС-5 B/1 D.06\' (Объект 730)
ИС-5 B/1 D(06\' (Объект 730)
ИС-5 B/1 D"06\' (Объект 730)';
my $regex = qr/(\b|[#])ИС-5 B\/1 D\.06' \(Объект 730\)(?=\b|[^-])/uip;
my $subst = '#ИС_5_Объект_730';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";