$re = '/(\b|[#])ИС-5 B\/1 D\.06\' \(Объект 730\)(?=\b|[^-])/ui';
$str = 'ИС-5 B/1 D.06\' (Объект 730)
ИС-5 B/1 Dd06\' (Объект 730)
ИС-5 B/1 D!06\' (Объект 730)
ИС-5 B/1 D_06\' (Объект 730)
#ИС-5 B/1 D.06\' (Объект 730)
ИС-5 B/1 D(06\' (Объект 730)
ИС-5 B/1 D"06\' (Объект 730)';
$subst = "#ИС_5_Объект_730";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;