re = /CC :' \d+' de DN : 'CN=(?<CN>[^,]+)[^']+'\n(- CODE \(serial : (?P<CODE>\d+)\) error.\n-+\n)+/
str = 'CC :\' 223\' de DN : \'CN=XXX 2025, ABCDEFGHIJKLMNOPQRSTUVWXYZ\'
- CODE (serial : 1234) error.
---------------------------------------------------------
- CODE (serial : 5678) error.
---------------------------------------------------------
- CODE (serial : 5678) error.
---------------------------------------------------------
- CODE (serial : 5678) error.
---------------------------------------------------------
- CODE (serial : 5678) error.
---------------------------------------------------------
CC :\' 224\' de DN : \'CN=YYY 2025, ABCDEFGHIJKLMNOPQRSTUVWXYZ\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end