re = /(?=^.{1,50}$)^[a-zA-Z]+([ \-'][a-zA-Z]+)*?$/m
str = '5
-- should fail
foster
-- should match
foster steve
-- should match
foster-morrison
-- should match
hello
-- should match
*RKER(($(#$)#$#L$KLK#$*
-- should fail
dfkfsdkfskdfjksjfksfksjfskjfksjfskfksjfksfksfskfd
-- should match
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkdffddfdfdfdgggfgfgfggggggg
-- should FAIL, too long
jkddkdkdkdkdkdkdkdkdkdkdkskdldkfdlkfdfkdfkdlkdkdkd-ffddfdfdfdgggfgfgfgggggggd
-- should FAIL, too long
dkfkerksf------aaa-----
-- should fail
test---me
-- should fail
test\'\'\'me
-- fails
foster-mo
-- should match
f-morrison
-- should match
griffith-joiner
-- should match
test-
-- should fail
-dkd
-- should fail
d\'andre
-- should match
d\'andre-jordan
-- should match
jordan-d\'andre-joe-b\'bob
-- should match
\\b[a-zA-Z]+?\\b :: matches a last name
\\b[a-zA-Z]+? [a-zA-Z]+?\\b :: matches a space\'d last name
\\b[a-zA-Z]+?\\-[a-zA-Z]+?\\b :: matches a hyphenated last name
\\b[a-zA-Z]+?\'[a-zA-Z]+?\\b :: matches an apostrophie\'d last name'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end