package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)dog.*apple`)
var str = `dog
klfdsjkfsdlkjsdf
apple
jksfdlkfsdj`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}