re = /([new]+\s+[york]+\s+[stae]+)/mi
str = 'Anything we wish to have before followed by a New York Statse then anything we wish to have after. Anything we wish to have before followed by a New Yokr State then anything we wish to have after. Anything we wish to have before followed by a New Yokr Stats then anything we wish to have after. Anything we wish to have before followed by a New York Statse then anything we wish to have after. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end