$re = '/^(0|\+\s?33|\+\s?377){1}\s{0,1}(\(0\)){0,1}\s?(6|7){1}(( |.){0,1}[0-9]{2}){4}/m';
$str = '+ 377 6 07 30 25 36
+377 6 07 30 25 36
+ 33 6 07 30 25 36
+33 6 07 30 25 36
06 07 30 25 36
0607302536
+33 (0)6 07 30 25 36
+377 (0)6 07 30 25 36
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);