#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\b(?:fees?|charges?)\b.*$"
Local $sString = "fees credit card" & @CRLF & _
"charges for interest" & @CRLF & _
"coffee shop" & @CRLF & _
"eeder cattle" & @CRLF & _
"" & @CRLF & _
"fee credit card" & @CRLF & _
"charge for interest" & @CRLF & _
"" & @CRLF & _
"test fees credit card" & @CRLF & _
"test charge for interest" & @CRLF & _
"" & @CRLF & _
"test afees credit card" & @CRLF & _
"test charged for interest" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")