package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\b(?:fees?|charges?)\b.*$`)
var str = `fees credit card
charges for interest
coffee shop
eeder cattle
fee credit card
charge for interest
test fees credit card
test charge for interest
test afees credit card
test charged for interest
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}