// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\b(?:fees?|charges?)\b.*$").unwrap();
let string = "fees credit card
charges for interest
coffee shop
eeder cattle
fee credit card
charge for interest
test fees credit card
test charge for interest
test afees credit card
test charged for interest
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}