$re = '/[a-zA-Z]\+[a-zA-Z]/m';
$str = 'a+b c +d g+ h i + j x+y';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);