using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w,\s-]{1,3}\.[a-zA-Z0-9]{2,4}$";
string input = @"a.exe
file
file.
file.ext
File.jpg
hi.mp3
fil.d2
file.longextension
565gfgf.mov
file#gg.jpg
a.ps1
123.hui
123.123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}