import re
regex = re.compile(r"^[\w,\s-]{1,3}\.[a-zA-Z0-9]{2,4}$", flags=re.MULTILINE)
test_str = ("a.exe\n"
"file\n"
"file.\n"
"file.ext\n"
"File.jpg\n"
"hi.mp3\n"
"fil.d2\n"
"file.longextension\n"
"565gfgf.mov\n"
"file#gg.jpg\n"
"a.ps1\n"
"123.hui\n"
"123.123\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")