package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(rgba\(.*?\))`)
var str = `const str = "linear-gradient(90deg, rgba(243,231,231,1), rgba(12,0,0,0.48))"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}