#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\+98?)?{?(0?9[0-9]{9,9}}?)$"
Local $sString = "09036565656" & @CRLF & _
"09151251685" & @CRLF & _
"09337729292" & @CRLF & _
"09136565655" & @CRLF & _
"09125151515" & @CRLF & _
"+989151251685" & @CRLF & _
"+9809151251688" & @CRLF & _
"09124527844" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")