import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+98?)?\\{?(0?9[0-9]{9,9}\\}?)$";
final String string = "09036565656\n"
+ "09151251685\n"
+ "09337729292\n"
+ "09136565655\n"
+ "09125151515\n"
+ "+989151251685\n"
+ "+9809151251688\n"
+ "09124527844\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}