re = /^(\+98?)?{?(0?9[0-9]{9,9}}?)$/m
str = '09036565656
09151251685
09337729292
09136565655
09125151515
+989151251685
+9809151251688
09124527844
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end