#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)[ \t]+\$[ ]*(?P<in_line>[^$\n]+?)[ \t]*\$[ \t]+"
Local $sString = "Lorem ipsum dolor sit ame $ a = \{ b, c \} $ Lorem 100 \$ ipsum" & @CRLF & _
"$$ \left \{ " & @CRLF & _
" \begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\y_2 =&2 x_2\\y_3 =&x_1 - x_2 + 3 x_3\end{array} " & @CRLF & _
" \right." & @CRLF & _
" \Leftrightarrow \left \{ " & @CRLF & _
" \begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\8 x_2 =&4 y_2\\8 x_3 =&-y_1 + y_2 + 3 y_3\end{array} " & @CRLF & _
" \right." & @CRLF & _
" $$ " & @CRLF & _
"Lorem ipsum dolor" & @CRLF & _
" $$ \left \{ " & @CRLF & _
" \begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\y_2 =&2 x_2\\y_3 =&x_1 - x_2 + 3 x_3\end{array} " & @CRLF & _
" \right." & @CRLF & _
" \Leftrightarrow \left \{ " & @CRLF & _
" \begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\8 x_2 =&4 y_2\\8 x_3 =&-y_1 + y_2 + 3 y_3\end{array} " & @CRLF & _
" \right." & @CRLF & _
" $$ " & @CRLF & _
"Lorem ipsum dolor $$$ Lorem ipsum dolor $$$. foo sit ame $ a = \{ b, c \} $ " & @CRLF & _
"" & @CRLF & _
"Il s'installe en ligne de commande avec le gestionnaire de paquets `opam`:" & @CRLF & _
"" & @CRLF & _
" $ opam update " & @CRLF & _
" $ opam install hevea" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")