re = /[ \t]+\$[ ]*(?P<in_line>[^$\n]+?)[ \t]*\$[ \t]+/m
str = 'Lorem ipsum dolor sit ame $ a = \\{ b, c \\} $ Lorem 100 \\$ ipsum
$$ \\left \\{
\\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\\\y_2 =&2 x_2\\\\y_3 =&x_1 - x_2 + 3 x_3\\end{array}
\\right.
\\Leftrightarrow \\left \\{
\\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\\\8 x_2 =&4 y_2\\\\8 x_3 =&-y_1 + y_2 + 3 y_3\\end{array}
\\right.
$$
Lorem ipsum dolor
$$ \\left \\{
\\begin{array}{cl}y_1 =&3 x_1 - x_2 + x_3\\\\y_2 =&2 x_2\\\\y_3 =&x_1 - x_2 + 3 x_3\\end{array}
\\right.
\\Leftrightarrow \\left \\{
\\begin{array}{cl}8 x_1 =&3 y_1 + y_2 -y_3\\\\8 x_2 =&4 y_2\\\\8 x_3 =&-y_1 + y_2 + 3 y_3\\end{array}
\\right.
$$
Lorem ipsum dolor $$$ Lorem ipsum dolor $$$. foo sit ame $ a = \\{ b, c \\} $
Il s\'installe en ligne de commande avec le gestionnaire de paquets `opam`:
$ opam update
$ opam install hevea
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end