#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\R+"
Local $sString = "put returns between paragraphs" & @CRLF & _
"" & @CRLF & _
"for linebreak add 2 spaces at end" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)