package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\R+`)
var str = `put returns between paragraphs
for linebreak add 2 spaces at end
`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}