use strict;
my $str = 'put returns between paragraphs
for linebreak add 2 spaces at end
';
my $regex = qr/\R+/p;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";