import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[ \\t]*[a-z][)]\\s*)?([^\\r\\n<]+(?:(?:\\r?\\n(?!\\s*[a-z][)])|<(?!br\\s*\\/?>(?:\\s*<br\\s*\\/?>)*\\s*(?:\\s+[a-z][)]|\\s*$)))[^\\r\\n<]*)*)(?:<br\\s*\\/?>\\s*)*";
final String string = "<strong>Preencha</strong> a lacuna e assinale a alternativa correta.<br />\n"
+ "<br />\n"
+ "I - capacitação técnico-profissional: Comprovação do licitante de possuir em seu quadro permanente, na data prevista para entrega da proposta, ________________, detentor de atestado de responsabilidade técnica por execução de obra ou serviço de características semelhantes, limitadas estas exclusivamente às parcelas de maior relevância e valor significativo do objeto da licitação, vedadas as exigências de quantidades mínimas ou prazos máximos (Lei 8.666/1993 Art N° 30).<br />\n"
+ "<br />\n"
+ "a)<strong>profissional</strong> de nível superior<br />\n"
+ "b)profissional de nível superior ou outro devidamente reconhecido pela entidade competente<br />\n"
+ "c)profissional capacitado<br />\n"
+ "d)profissional de nível minimamente técnico<br />\n"
+ "e)profissional especializado no objeto da <strong>licitação</strong><br />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}