$re = '/<p>The post <a\s+.*?href=".*?"\s+.*?>.*?<\/a> appeared first on <a\s+.*?href=".*?"\s+.*?>.*?<\/a>.<\/p>
/m';
$str = '<p>The post <a rel="nofollow" href="link" >title</a> appeared first on <a rel="nofollow" href="Website.com" >Website</a>.</p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);