$re = '/<Component[ \w=\{\}>\(\)\n;?".-:]*prop/m';
$str = '<Component
value="lol"
onClear={() => { onChange?.(""); }}
prop={"test"}
>
<Component
value="lol"
prop={"test"}
/>
</Component>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);