re = /[^\P{L}a-z]+(\.[^\P{L}a-z]+)+/i
str = ' لــــیككاثو.لثو 普遍接受测试.世界 ya.ru домен.рф abcd.com شبكة.شبكة '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result