# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(?:(?:\S\s?)*\s+){2}| +(?= )"
test_str = (" 0 4D1F 8172 DC.L $4D1F8172 ; Rom CheckSum\n"
" 4 0040 002A DC.L $0040002A ; Boot Vector = EBootStart\n"
" 8 00 DC.B $00 ; Machine Type\n"
" 9 75 DC.B $75 ; Rom Version\n"
" A 6000 0056 Bra L3\n"
" E 6000 0750 Bra L62\n"
" 12 6000 0044 Bra L2\n"
" 16 6000 0016 Bra E_6\n"
" 1A 0001 76F8 DC.L $000176F8 ; offset of Resources in ROM\n"
" 1E 4EFA 2BFC Jmp P_mvDoEject\n"
" 22 0000 0000 DC.L $00000000\n"
" 26 0000 0000 DC.L $00000000\n"
" \n"
" 1FFE2 4B57 4B20 4C41 DC.B 'KWK LA'")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.